Tutoriels vidéo art graphique gratuits

 
Bienvenue, Invité. Merci de vous connecter ou de vous inscrire.
Pages: [1]   En bas

Auteur Sujet: problème dans le serveur distant  (Lu 3564 fois)

lagrandemistinguette

  • Wisi Addict
  • ***
  • Hors ligne Hors ligne
  • Messages: 146
    • Live Messenger (MSN) - lagrandemistinguette@hotmail.fr
    • Voir le profil
problème dans le serveur distant
« le: octobre 05, 2009, 00:14:37 am »

Bonjour,

j' apprend seule la création d'un site internet.

J'ai crée un site basique, pour un premier exercice, qui sera un site pour ma mère.

>>>>>>J'ai crée des balises div, dans lesquelles j'ai inséré des images, textes, tableaux, avec un ou plusieurs styles CSS.
Jusque là mis à part des difficultés à insérer une image de la manière dont je souhaitais, je n'avais pas trop de problèmes.

>>>>>>J'ai voulu insérer un formulaire.
J'ai appris donc que soit on avait CS4 et que le code de validation se faisait sans trop de difficultés, soit on avait une version ultérieure et fallait soit y inclure un script php (choses que je ne connaissais nullement par avant)
Je me suis lancée à la recherche de scripts, mais pas seulement j'essayais avant tout de comprendre et trouver la méthode de validation de formulaire par le code. Que fallait il inscrire ? j'ai analysé un peu les codes des scripts pour
comprendre ce que je faisais.

>>>>>>Je suis arrivé à lire de la doc sur le php et j'ai compris que la validation (je me trompe peut être, sans doute, d'ailleurs), était déclarée grâce à plusieurs lignes de code, via un script par exemple, ou que l'on pouvait créer des formulaires par le biais d'une base de données (pour faire court !)

>>>>>>Pour le moment le temps de choisir un bon hébergeur et le meilleur pack (je vais poser une question à ce sujet dans le bon forum), je me suis mise sur ifrance, en gratuit, alors je me suis dis que peut être le problème de la validation de mon formulaire avec le script que j'ai inclus dans une page de mon site avec l'extension .php, était juste mais que c'est l' hébergeur qui ne prenait pas en compte ma page contact (formulaire). j'ai juste créer la page du contact(formulaire) avec les balises form, et créer un renvoi vers la page php en question.

Quand on essayait le formulaire sur ifrance, un message m'indiquait que le message avait bien été envoyé et je n'ai jamais rien reçu sur ma boite mail.
Etait ce Ifrance qui ne me permet pas d'accéder à la validation ?
Etait ce moi qui doit faire une ou d'autres manipulations comme créer une base de données pour accéder aux messages des internautes ?
Ou était ce un autre problème ?

J'ai essayé avec une dizaine de scripts différents avec des sites d'autocréation de formulaires, comme celui ci : http://www.ge-net.ch/page/rw-wfco-owb-0.html
Ou avec ce site là  : http://conseilscreation.free.fr/pages/contact.php

Une fois je suis tombée sur un site qui me permettait la validation du code et laréception du mail. mais il y a vait pas mal de pubs. Point trop n'en faut même si c'est pour le moment qu'une prévisualisation du site, si ya trop de pubs (celle d'ifrance et celle du site permettant la création d'un formulaire) on y voit plus rien.

>>>>> Mon intérêt en plus est d'apprendre quel code il faut pour le type de formulaire que je souhaitais au départ.
Le script proposé par ifrance fonctionnait également mais je ne pouvais donc pas changer le style ni l'organisation,
J'ai finis par réussir à en garder deux sous le coude qui me semblait plutôt pas mal en attendant de révéler ce fameux mystère de non réception des mails de remplissage de formulaires.

>>>>>>J'ai galéré durant trois jours durant pour laisser de côté et reprendre aujourd'hui quelque chose de différent en attendant de mieux comprendre.
(j'ai posé des questions à ifrance.).
Je modifie quelques photos sur une page !!!!
et voilà le hic finale ! impossible impossible d'avoir la même chose que sur le serveur local (dream en local)
>>>>>Sur internet explorer ça marche à peu près correctement mais le site est complètement à gauche de l'écran !!! :(  !)
>>>>Et sur firefox ça marche pour certaines pages, mais pas toutes alors que j'ai exactement les liens qu'il faut.
Le plus fort c'est que j'ai supprimé les anciennes photos qui me servaient pour la maquette, ils ne sont plus sur mon ordi, nulle part, ni sur le site en distant car j'ai supprimé et resynchroniser le tout, et le site affiche toujours et encore la même page avec les anciens liens.... c'est à devenir cinglée !!!

>>>>>> J'ai donc supposé que c'était peut être les pages du formulaires qui me faisait tout coincé !
J'ai vérifié aussi la gestion du site.
Je ne sais plus quoi faire.

regardez le site sur internet explorer, et sur firefox.... ! ;)
ne vous moquez pas je suis débutante... mais j'ai pleins d'idées pour l'améliorer.
http://lespetitsberlingots.ifrance.com/


Si quelqu'un pouvait me sortir de cette panade !!!! merci ! ;) et désolé pour le roman !!!

lagrandemiss (ça faisait longtemps que j'étais pas venue par ici alors merci pour votre écoute et vos espérées réponses !)



J'ai lu pas mal de livres, j'ai un dvd "CS4 dream" par Jean Luc Delon, et j'ai "dream pour les nuls", un "dream MX 2004" (miccro application), "donne moi ce que je veux", de Patricia gallot-Lavalée, le référencement sur google"
et deux livres que j'ai pas encore regardé sur le php et le mysql. empruntés à la biblio. Il faut que je les potasses.
IP archivée

lagrandemistinguette

  • Wisi Addict
  • ***
  • Hors ligne Hors ligne
  • Messages: 146
    • Live Messenger (MSN) - lagrandemistinguette@hotmail.fr
    • Voir le profil
Re : problème dans le serveur distant
« Réponse #1 le: octobre 05, 2009, 00:17:29 am »

Je précise que les photos dans "gilets" sont des photos de maquette pour le moment. Il n' y a que cet onglet qui fonctionne dans modeles. Et la page contact fonctionne également normalement. J' y ai juste supprimé momentanément le formulaire.

merci
« Modifié: octobre 27, 2009, 16:37:13 pm par lagrandemistinguette »
IP archivée

Eddy

  • Global Moderator
  • Wisi Comment on décroche
  • *****
  • Hors ligne Hors ligne
  • Messages: 3239
  • Éternel apprenti.
    • Voir le profil
    • Scriptopedia.org
    • E-mail
Re : problème dans le serveur distant
« Réponse #2 le: octobre 05, 2009, 05:26:47 am »

Bonjour.
Suis pressé pour aller plus loin pour le moment mais on y reviendra...

commence par essayer de remplacer

#container {
   background-color: #FFFFFF;
   width: 940px;
   margin-right: auto;
   margin-left: auto;
}

Par

#container {
   background-color: #FFFFFF;
   width: 940px;
   margin: 0 auto;
}
IP archivée
Config : I-Mac 27" Core I5 12Go RAM - OSX 10.10.X

lagrandemistinguette

  • Wisi Addict
  • ***
  • Hors ligne Hors ligne
  • Messages: 146
    • Live Messenger (MSN) - lagrandemistinguette@hotmail.fr
    • Voir le profil
Re : problème dans le serveur distant
« Réponse #3 le: octobre 05, 2009, 12:23:44 pm »

Dans ma page style css ? pourquoi ? je voudrais juste comprendre ! (et pas faire ou rectifier à l'aveuglette sans rien capter à ce que je fais ) Merci

Apparemment le site fonctionne auj ! à rien y capter !
hier soir je l'ai essayé plusieurs fois et ça marchait une fois sur deux !

merci pour toutes les réponses à mes multiples (hihihi ) questionnements !
IP archivée

Eddy

  • Global Moderator
  • Wisi Comment on décroche
  • *****
  • Hors ligne Hors ligne
  • Messages: 3239
  • Éternel apprenti.
    • Voir le profil
    • Scriptopedia.org
    • E-mail
Re : problème dans le serveur distant
« Réponse #4 le: octobre 05, 2009, 16:16:21 pm »

Pour moi sous IE, il est toujours à gauche....

En fait, j'ai regardé ta CSS et tu pourras l'alléger de moitié environ.
Lorsque tu appliques des propriétés à certaines choses, tu peux les grouper, le site n'en sera que plus rapide.

Le "margin: 0 auto;'
Se lit comme suit, les marges seront à 0 en haut et en bas et en automatique sur la gauche et la droite.
Lorsque tu as deux valeurs, elles sont toujours lisible de la sorte, d'abord "Haut/Bas" puis "Gauche / droite".

Si tu as 4 bords d'un pixel en trait continu et rouge, tu peux inscrire le code comme suit :

border: 1px solid red; //Ce code suffit pour affubler tes 4 bords de couleur rouge sur un Pixel d'épaisseur.

Un bon complément pour tes propriétés CSS se trouve sur le siteduzéro, regardes ce qu'ils appèlent les méga-propriétés.
IP archivée
Config : I-Mac 27" Core I5 12Go RAM - OSX 10.10.X

lagrandemistinguette

  • Wisi Addict
  • ***
  • Hors ligne Hors ligne
  • Messages: 146
    • Live Messenger (MSN) - lagrandemistinguette@hotmail.fr
    • Voir le profil
Re : problème dans le serveur distant
« Réponse #5 le: octobre 07, 2009, 13:44:53 pm »

merci pour tes réponses,  ;)

je regarde un tas de sites expliquant le css notamment le site du zéro mais parfois rien n'est évident.... J'ai du mal avec le code moi je ne ferais pas des masses de développements..... je suis plus print ya rien à faire ! mais bon faut que je comprenne mes erreurs pour avancer ! le site fonctionne maintenant mais je n'ai plus ma page de formulaire....
Bon je vais d'abord faire des petites choses en javascript avantd e me lancer dans le php à l'aveuglette.

Merci !!!
IP archivée

Eddy

  • Global Moderator
  • Wisi Comment on décroche
  • *****
  • Hors ligne Hors ligne
  • Messages: 3239
  • Éternel apprenti.
    • Voir le profil
    • Scriptopedia.org
    • E-mail
Re : problème dans le serveur distant
« Réponse #6 le: octobre 07, 2009, 16:40:04 pm »

Si tu n'as jamais codé, le php promet d'être une grande aventure... C'est pas facile.
IP archivée
Config : I-Mac 27" Core I5 12Go RAM - OSX 10.10.X

lagrandemistinguette

  • Wisi Addict
  • ***
  • Hors ligne Hors ligne
  • Messages: 146
    • Live Messenger (MSN) - lagrandemistinguette@hotmail.fr
    • Voir le profil
Re : problème dans le serveur distant
« Réponse #7 le: octobre 08, 2009, 01:16:40 am »

Non j'apprends seule à petits pas en m'exerçant à créer un premier site d'ailleurs si vous voulez me faire des remarques, allez y mais ne me bousculez pas trop, je suis lente, mais travailleuse !

Je continue également de me former au métier d'infographiste metteur en pages.
C'est pas simple car ma maladie chronique me ralentit beaucoup. Parfois j'ai des gros coups de flippes en me disant que je n' y arriverais pas parce que les problèmes cognitifs sont là, eux aussi.

Mais je garde espoir, en vain...

voili ! merci pour toutes vos aides précieuses !
IP archivée
 



Wisibility est un sité dédié à la formation aux métiers l’image. Vous y trouverez différentes ressources vous aidant à maîtriser les logiciels graphiques tels que Photoshop, Lightroom, Illustrator, InDesign, Flash… Aujourd’hui, Wisibility réunie plus d'une vingtaine d’experts, intervenant en Entreprise pour former graphistes, webdesigners, développeurs web, photographes, monteurs, trucistes…
Depuis 2006 nous nous sommes spécialisés dans les tutoriels vidéos permettant de se former à distance. Notre forum très actif, géré par une équipe de bénévoles répondra à vos demandes. Vous pourrez également profiter de nos émissions et reportages sur la Wisi TV.
Contact - Wisibility est une marque déposée

Blog - Tutoriels - Wisi TV - Forum